Topcased

One of the initial reasons for the creation of PolarSys was the organization of Very Long Term Support for TOPCASED and the creation of a sustainable ecosystem for open source tools for embedded systems. In July 2015, the TOPCASED servers were shut down and redirected to this page where we provide resources to help users migrate from the old TOPCASED uml and sysml editors to the corresponding PolarSys Solution: Papyrus.

TOPCASED 5.3.1 was the last version of TOPCASED and was based on Eclipse 3.7.2 (Indigo). In this version, Papyrus 0.8 was used as the new UML/SysML editor. This version is definitely deprecated and no longer under development.

Downloads: The Topcased team provided this last binary for Windows and the last sources in case you want to recompile it.

Previous users of TOPCASED can use Papyrus + Gendoc + Acceleo to benefit from features that were used in most of the use cases. There is no integrated RCP version with all theses components for the moment, but feel free to address this issue on the Papyrus forum.

FAQ

Here is a list of some frequently asked questions when people migrate from Topcased to Papyrus:

  • How to migrate my models
    The uml part of your models should be migrated automatically by the Eclipse modeling UML framework. But the graphical part might be lost. In case you have a large legacy of models that need to be migrated, some PolarSys members have both expertise and tooling to help with migration. Get in touch at info@polarsys.org and we will make the connection.
  • Where is Topcased Req
    TopcasedReq is deprecated, and no more under development. You can find a miror of the last status of the project on this github repository. If you need requirements traceability, you should give a look at ReqCycle, the PolarSys project that addresses this topic.